好股网首页 www.gupiao18.com 股票查询最好股票网 个股数据查询好股网 保存本站网址  股票网|好股网|股票查询网
好股网
好股网 股票查询 ddx在线 爱股实时行情 超赢资金 最好股票网
您的位置:好股网 > 股票公式 > 通达信公式
股票行情查询:

通达信抓牛法宝主图指标公式

2019/9/4 20:55:21

{筹码带}
N:=10;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,21);
VAR81:=REF(CLOSE,N)-REF(ATR,1);
筹码线:=HHV(VAR81,21),COLORYELLOW;
上:=(1+7/100)*筹码线;
下:=(1-7/100)*筹码线;
中:=(上+下)/2;
XGD:DRAWBAND(上,RGB(258,88,1),下,RGB(258,88,1));
{XGD:DRAWBAND(上,RGB(136,30,0),下,RGB(0,0,0));}
UPPER: MA(CLOSE,60)+ 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
LOWER: MA(CLOSE,60)- 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
{UPPER90: MA(CLOSE,90)+ 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;
LOWER90: MA(CLOSE,90)- 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;}
{盖住双横杠}
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;
{牛熊线}
短期线:EMA(CLOSE,7),COLORWHITE,LINETHICK1;
中期线:EMA(CLOSE,25),COLORFF00FF,LINETHICK1;
长期线MACP:EMA(中期线,55),COLORYELLOW,LINETHICK2;
牛熊分水岭905:EMA(CLOSE,905),COLORRED,LINETHICK3;
大牛控盘线:MA(CLOSE,1650),COLORGREEN,LINETHICK3;
X_3:=MAX(DYNAINFO(3),DYNAINFO(5));
X_4:=MIN(DYNAINFO(3),DYNAINFO(6));
银河线:=(X_3-X_4);
DRAWICON(CROSS(中期线,长期线MACP),长期线MACP,23);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWICON(VAR19 AND C>短期线,L*0.998,1);
DRAWICON(VAR1A,H*1.002,2),NODRAW;
TJ5:=REF("CCI.CCI",1)<-100 AND "CCI.CCI">REF("CCI.CCI",1);
TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);
TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);
TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);
大底:=CROSS(TJ8,0.5);
DRAWICON(大底,L*0.991,11);
T1:EMA(SLOPE(CLOSE,34)*20+CLOSE,75),COLORYELLOW,NODRAW;
T2:MA(C,120),COLORCYAN,LINETHICK2,NODRAW;
T3:MA(C,250),COLORGREEN,LINETHICK2,NODRAW;
乖离线:=((C-REF(T1,1))/20+T1)*1.20;
TT1:=CROSS(T1,T2)AND CROSS(T1,T3) AND V>REF(V,1);
TT2:=T1>REF(T1,2) AND V>REF(V,1) AND CROSS(C,T1);
DRAWICON((T2>=REF(T2,1) AND CROSS(C,T1) AND CROSS(C,T2) AND V>REF(V,1)),L*0.997,9);
DRAWICON(TT2,L*0.995,11);
DRAWICON(CROSS(C,乖离线) AND L!=H,H*1.005,12);
N1:=10;
N2:=3;
N3:=6;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
STICKLINE(((HSL * 0.4) >= 0),((HSL/1000) * 1.0),0,1,0),COLORRED,NODRAW;
STICKLINE(((HSL * 0.4) < 0),((HSL/1000) * 1.0),0,1,0),COLORBLUE,NODRAW;
力度: (HSL / 1000),LINETHICK0,NODRAW;
A1:=SUM(力度,N1);
A2:=EMA(A1,N2);
A3:=EMA(A1,N3);
累积能量:A1,NODRAW;
BIAS1:(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,NODRAW;
买:DRAWICON(CROSS(A1,A3) AND C>短期线,L*0.998,1),NODRAW;
卖:DRAWICON(CROSS(A3,A1) AND BIAS1>1,H*1.002,10),NODRAW;
VAR1Y:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2Y:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3Y:=SMA(VAR2Y,2,1);
卖出:100+(-ABS(VAR1Y)),NODRAW;
预防:SMA(VAR3Y,2,1),COLORRED,LINETHICK2,NODRAW;
DRAWICON(CROSS(预防,卖出),H*1.02,2),NODRAW;
VV:=(C+L+H)/3;
DSA:=SMA(EMA(VV,2),2,1)LINETHICK2,COLORRED;
Y396:=DSA;
险1:=Y396*1.1,COLORLIRED;
险2:=Y396*1.125,COLORLIRED;
险3:=Y396*1.15,COLORLIRED;
良1:=Y396*0.9,COLORLIBLUE;
良2:=Y396*0.875,COLORLIBLUE;
良3:=Y396*0.85,COLORLIBLUE;
变色:=IF(Y396{WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;}
{WSR2:=CROSS(WSR1,5);}
{WSR3:=CROSS(8,WSR1);}
{WSR4:=CROSS(WSR1,-5);}
{WSR5:=CROSS(WSR1,-8);}
{WSR6:=WSR3;}
{WSR7:=WSR4 OR WSR5;}
{WSR8:=WSR7 AND FILTER(WSR7,5);}
{WSR10:DRAWICON(WSR8,L-0.01,1);}
{WSR9:=WSR6 AND FILTER(WSR6,5);}
{WSR11:DRAWICON(WSR9,H+0.01,2);}
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5);
WSR10:
DRAWICON(WSR8,L-0.01,1),NODRAW;
WSR9:=WSR6 AND FILTER(WSR6,5);
WSR11:DRAWICON(WSR9,H+0.01,10),NODRAW;
WSR12:=O<良3;
DRAWICON(WSR12 AND FILTER(WSR12,12),L-0.03,9);
W1:=C>REF(C,1) AND MACD0 AND VW2:=C>REF(C,1) AND MACD<0 AND MACDXG:=W1 OR W2;
VAR1AA:=AMOUNT/VOL/7;
VAR2AA:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3AA:=SUM(AMOUNT,10)/VAR1AA/7;
VAR4AA:=DMA(VAR2AA,VOL/VAR3AA);
VAR5AA:=(CLOSE-VAR4AA)/VAR4AA*100,COLORLIMAGENTA;
XG1:=CROSS(VAR5AA,MA(VAR5AA,2)) AND VAR5AA<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1 AND L<良1;
WSR13:=O>良3 AND L<良1 OR XG3;
DRAWICON(WSR13 AND FILTER(WSR13,10),L-0.03,5);
WSR14:=H>险3;
DRAWICON(WSR14 AND FILTER(WSR14,15),H+0.03,10);
WSR15:=H<险3 AND H>险2;
DRAWICON(WSR15 AND FILTER(WSR15,5),H+0.03,4),NODRAW;
ZLCM:=EMA(WINNER(CLOSE)*70,3),NODRAW;{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100,NODRAW;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100,NODRAW;{//主力控盘筹码比率}
ZZLJJ:=EMA(ZZLKP,89),NODRAW;{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ),NODRAW;{//资金流入强度}
天界:INTPART(ZSHTL),COLORCYAN,LINETHICK2,NODRAW;
凡间:ZJLRQD,LINETHICK2,COLORRED,NODRAW;
DRAWICON(CROSS(天界,凡间),H*1.02,12);
{涨停跌停标记}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
均价线:=AMOUNT/V/100;
STICKLINE (涨停, OPEN ,CLOSE,4,0),COLORBLACK;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
{基本面概况}
DRAWTEXT_FIX(ISLASTBAR,0.0,0,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,FGBLOCK),COLORWHITE;

股票公式推荐
在线查股
个股查股导航:股票行情查询 DDX在线查询 超赢数据查询 资金流向 千股千评 个股最新消息 大小非解禁 十大股东查询 分红配股查询 业绩预告查询
ST厦华 600870+5.17% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
*ST节能 000820+5.12% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
新宝股份 002705+5.11% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
凯撒文化 002425+5.08% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
联诚精密 002921+5.08% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
ST成城 600247+5.08% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
华升股份 600156+5.08% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
武进不锈 603878+5.06% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
*ST大控 600747+5.05% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
洽洽食品 002557+5.02% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
商务合作:在线客服 好股网 股票查询(股票DDX在线 证券配资 大智慧超赢数据 大小非解禁时间表)
好股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机端(适合手机用户访问) | 电脑端(适合电脑或大屏用户)